How do I make sound work when connecting to a Windows XP system?

en10101301

This topic applies to:  xp.png

First, you must have Splashtop Streamer installed on a computer running the Windows XP system.

 

Sound_Setting_page.PNG

 

The Setting tab in the Splashtop Streamer box will appear similar to the above illustration.  By default, the When a remote client connects, redirect all sound to the client, and mute this computer checkbox is not checked.

Click the Advanced Settings button to open another dialog box, as shown below.  The "PCI-Aux Volume" or "Stereo Mix" audio device is already selected for you.  If not, please manually ensure that the checkbox is un-checked and that "Stereo Mix" is selected.

 

Sound_Aux_Advance_db.PNG

 
note.gif  NOTES:

  • Unlike Vista & Windows 7, there is no standardized audio API in Windows XP.   We are constantly surveying and exploring for work-arounds and a better solution.  Please check back at our website frequently for updates/announcements.
  • On Windows XP systems, in most cases, the When a remote client connects, redirect all sound to the client, and mute this computer checkbox needs to be UN-checked in order to enable sound to work on the tablet/phone.  So if the computer is muted (that is, the setting above is CHECKED), then the tablet/phone will not be able to play back any sound.

    However, this checkbox can still be checked in the event that the audio codec drivers do provide the capability to record audio output while muted.

  • The items available in the drop-down list will depend on your language setting and your audio driver.  If "Stereo Mix" is not available, please try options which would be similar.

 

  • If you are using the Realtek HD audio driver for XP, this driver will automatically Mute the audio when Splashtop Streamer is connected!  Therefore, in order to get sound on your tablet, please make sure the following settings are correctly used:

1.  Verify that Realtek HD Audio Input-Stereo Mix is the selected audio device on the Splashtop Streamer, as shown in the Streamer's Advanced Settings box below; and
2.  Confirm that the  Wave channel has been un-muted when connected, as shown below.

WinXP_Adv_Retailtek_Audio.PNG

 

  • For another trick to make sound work on XP, see the first tip in the Comments section below.

 

Have more questions? Submit a request

22 Comments

  • 0
    Avatar
    Splashtop Support

    Here is a special work-around trick for the no-sound issue on Windows XP.  You can loop back headphones out to the audio-line-in by an audio cable like this:  (i.e. on a notebook, plug in both jacks, for "headphone" and "microphone").

    aux_line2.jpg

    Please also remember to select "xxx Audio-line-in" in Splashtop Settings on the  computer side, and UN-check this option:  When a remote client connects, redirect all sound to the client, and mute this computer.

  • 0
    Avatar
    lorenzo augelli

    Hi,

    I've problems with earing sounds on my iPad when connecting... my PC runs Windows XP and the only audio device is an external Tascam FireOne.

    Help me, please :-)

    Lorenzo

  • 0
    Avatar
    con

    im having the same problem... i  cant hear sound from the ipad... even though i make all the settings like you said... i have win xp and creatve sounblaster 2zs pro on the pc ... and ipad 2 like a remote... 

  • 0
    Avatar
    farhan alhashemy

    I have the same problem I cant hear sound in my iPad and iPhone my computer is mac.

     What is the solution to this problem??

  • 0
    Avatar
    Jaff

    @farhan alhashemy,

    If your Streamer is Mac, this link may help for you to configure settings for Soundflower.

    http://support-remote.splashtop.com/entries/514300-why-is-there-no-sound-on-my-mac-i-just-hear-noise-coming-from-my-mac-s-microphone

  • 0
    Avatar
    Macbrand29
    So in order to stop sounds from the mic streaming from XP you have to disable all sounds being streamed. Defeats the purpose of Splashtop if you want to stream a movie or play a game. I hope a work around can be found otherwise any media work is useless.
  • 0
    Avatar
    storm

    THINKPAD T410,Streamer中找不到‘立体声混音’选项,于是在虚拟机中安装XP,在虚拟机的XP中,安装Streamer,发现有‘Creative Sound Blaster PCI-辅助音量’及‘Creative Sound Blaster PCI-立体声混音’选项,但仍然不能发声。想通过文中所描述第二种方法,用音频线接音响孔和麦克风孔,但发现T410无麦克风孔,麦克风已集成在屏幕下方。最后只有放尝试。

    注:虚拟机中的XP播放视音频文件正常。

  • 0
    Avatar
    John Dieudonne

    Kind of frustrating.  Same problem on this system running Windows XP on a dual core with plenty of power and side-by-side on the wifi network.  Tried all of the setting combinations recommended and still no joyful noise from the the (new)iPad(3).  Everything seems to be functioning except the sound so the app becomes less than useful for its intention.  Agree that movies are clearly out of the running in this situation, which was the primary desire.  Any hope for a fix or even some sort of future upgrade in any of the software(s)?  Pity that everything else (video, controls) seems to be working just fine. 

  • 0
    Avatar
    RFgroup
    I'm having sound problem with win 7. I don't have sound redirect to my ipad 2.
  • 0
    Avatar
  • 0
    Avatar
    hattab

    Hello I have just bought your application and I am very disappointed the sound is not manage towards my iPad my system are xp thank you for giving me the solution

  • 0
    Avatar
  • 0
    Avatar
    Splashtop Support

    (blocked message from user--hattab)

    Oh!, hi

    Thanks for your support! I already fix the issue. Apparently on of the kids
    move the mute key and set it on mute. I figure it out later on.
    But thanks for your help!

  • 0
    Avatar
    Patrick Tierney

    I have made all of the suggested mods to my XP system, but the sound still does not stream. I'm very disappointed since the affected machine is my home theater computer with all the content.

  • 0
    Avatar
    Volkan

    Hi 

    I tried all the suggestion but it doesn't work. I have galaxy tab 2 and windows 7 laptop. When i go to advance setting part, It is not the same like here:Sound_Aux_Advance_db.PNG

    Mine says Port number and under that There is a Check Box for " Help improve this product by submitting anonymous crash reports..."

     

    Please help me, I can't get a sound on my tablet when i connected to the laptop.

  • 0
    Avatar
    Jaff

    @Volkan,

    This article is for XP only, please check this link to see if all the settings on Win7 has been properly setting up.

    http://support-remote.splashtop.com/entries/514294-why-is-there-no-sound-on-my-vista-or-windows-7-system

  • 0
    Avatar
    Jaff

    Hi all,

    We have a new finding about no sound issue on XP, please have a check on your case:

    If you are using Realtek HD audio driver for XP, this driver will automatically mute audio when Splashtop Streamer is connected. Please confirm your case if  Realtek HD Audio Input-Stereo Mixer is selected and Wave channel is unmuted when connected. (see above original article for screenshot)

  • 0
    Avatar
    polson

    Have tried all work arounds for XP realtek, and still can't get sound on the tablet......

  • 0
    Avatar
    George Fievet

    Is there an update on this support issue for Streamer 2.0?  I've got a Windows XP virtual machine running inside of a Mac Fusion host.  Sound works perfectly when connecting to my Mac.  Virtual machine sound also works when connecting to my Mac, so I know sound is working from the virtual machine.

    However, I get no sound when connecting directly to my Windows VM session.  

    Listed sound card is a Creative AudioPCI (Creative Sound Blaster PCI in Streamer settings).  I have tried selecting and de-selecting the redirect audio option and selecting stereo mix instead of aux volume in the Streamer settings.

    Is this something that just isn't supported from a VM?  Video works perfectly...only audio is an issue.

  • 0
    Avatar
    Michael
    This is how I got sound to be transferred to my ipad 3 on iOS 5.1.1 running splashtop 2 version 2.2.0.9, from my pc running windows xp service pack 3 with Realtek HD sound... First, my settings on my pc are as follows in the picture while your ipad is viewing your pc desktop through splashtop. The volume levels that I chose for the unmuted options were very important to not be too high/loud. Then I bought a "male to male" audio cable to fit my pc's headphone and microphone ports. Before I plugged anything into the ports I started a video on YouTube, still connected through splashtop. I plugged the first end of the cable into the headphones port then the other end was placed into the microphone port. Viola! I had sound, I hope this works for you.


    IMG_1539.PNG
  • 0
    Avatar
    Michael
    Splashtop 2 Sound working xp ipad
  • 0
    Avatar
    Michael
    UPDATE This is how I got sound to be transferred to my ipad 3 on iOS 5.1.1 running splashtop 2 version 2.2.0.9, from my pc running windows xp service pack 3 with Realtek HD sound... First, my settings on my pc are as follows in the picture while my ipad was viewing my pc desktop through splashtop 2. The "master volume" and "recording volume" settings windows were accessed by clicking on a volume icon that was located on the START bar by the clock on the right. I'm sure this can be accessed through control panel as well. It can be googled, "how to xp master volume settings" "how to xp recording volume settings". The volume levels that I chose for the unmuted options were very important to not be too high/loud. When I raised any of the volume levels too high, there was a high pitch disturbance. The splashtop 2 settings were also open and the settings tab was selected. My settings were as follows... Enable Auto Launch [checked], Mute This Computer [unchecked], Use The Following Audio Device [input-line volume]. Then I bought a "male to male" audio cable to fit my pc's headphone and microphone ports. Before I plugged anything into the ports I started a video on YouTube, still connected through splashtop. I plugged the first end of the cable into the headphones port then the other end was placed into the microphone port. Viola! I had sound. I know that it's not proper, but it worked for me. I hope this works for you. This explanation has more detail than the version I wrote last night.
Please sign in to leave a comment.